DC discharge simulation with idle time

Vasily Kozhevnikov
Dear Friends,

Im simulating low-pressure 2D DC discharge with COMSOL Plasma module. The peculiarity of this simulation is in the anode voltage supply. Anode voltage waveform is represented by small duty cycle pulse train (rectangular + long pause each). The high voltage application time is much smaller than entire pulse period, but it is enough to ignite self-sustained discharge ~ 2 us at low pressure. After the ignition of self-sustained discharge voltage source switching off for the long time about ~ 100 us.
COMSOL successfully simulates the ignition, but after the switching the source off at about 20-30 us from the beginning of the simulation I receive "Repeated error test failures. May have reached a singularity" error for BDF and Generalized alpha time-dependent solvers both. Also I've tried to set Relative tolerance at specified value from 0.01 down to 1e-5.
I can't explain why is it so? There is no convection at that time point, only diffusion and surface reactions. Do you know how to avoid such disconvergencies? Please, share your opinions.

5 Replies Last Post 26-Aug-2017 1:01 am EDT
Posted: 9 months ago 11-Jan-2017 3:38 am EST
Hi,
In begining try to do your simulation in 1D if possible to see if the problem don't come from your chemical reaction.
In 2D plasma simulation the mesh must be very small (small than Debye lenth).
You can try also to use iterative solver.
Good luck
Hi, In begining try to do your simulation in 1D if possible to see if the problem don't come from your chemical reaction. In 2D plasma simulation the mesh must be very small (small than Debye lenth). You can try also to use iterative solver. Good luck

Posted: 2 months ago 20-Aug-2017 10:30 pm EDT
i thought the mainly reason is the plasma can not sustain, the error will come. you can change solve time.
i thought the mainly reason is the plasma can not sustain, the error will come. you can change solve time.

Vasily Kozhevnikov
Posted: 2 months ago 23-Aug-2017 3:40 am EDT
Hello,

Concerning the problem I've reporter earlier, I've found the way to solve it. First of all, I considered similar 1D problem with same plasma physics and received the same error. Then I've changed following things:

1) Time stepping/BDF Method Free was turned to Strict;
2) Maximum stepsize was set to 1[us] << voltage source period;
3) In "Method and Termination" the "Nonlinear method" from "Constant" was switched to "Automatic (Newton)"
and "Maximum number of iterations" was set to 25 and "Tolerance factor" to 0.01

after that everything become to work, but extremely slow. Who knows how to make computations faster on the same PC?
Hello, Concerning the problem I've reporter earlier, I've found the way to solve it. First of all, I considered similar 1D problem with same plasma physics and received the same error. Then I've changed following things: 1) Time stepping/BDF Method Free was turned to Strict; 2) Maximum stepsize was set to 1[us]

Posted: 2 months ago 24-Aug-2017 3:40 pm EDT
I think, major factor was setting time stepping to STRICT.
Now, you can set mixed multi-time-step algorithm for ON or OFF duty cycle.
--
JB
I think, major factor was setting time stepping to STRICT. Now, you can set mixed multi-time-step algorithm for ON or OFF duty cycle. -- JB

Vasily Kozhevnikov
Posted: 2 months ago 26-Aug-2017 1:01 am EDT
>>>Now, you can set mixed multi-time-step algorithm for ON or OFF duty cycle.
Please, could you recommend how to make it?
>>>Now, you can set mixed multi-time-step algorithm for ON or OFF duty cycle. Please, could you recommend how to make it?

Reply

Please read the discussion forum rules before posting.

Please log in to post a reply.

Note that while COMSOL employees may participate in the discussion forum, COMSOL® software users who are on-subscription should submit their questions via the Support Center for a more comprehensive response from the Technical Support team.